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LDAP stands for Lightweight Directory Access Protocol, which is a client-server protocol 

for accessing a directory service. LDAP is a directory service protocol that runs over 

TCP/IP. The nitty-gritty details of LDAP are defined in RFC 1777 "Lightweight Directory 

Access Protocol". 

The following gives an overview of LDAP from a user's perspective. 

What kind of information can be stored in the directory? 

The LDAP information model is based on entries. An entry is a collection of attributes 

that has a globally-unique Distinguished Name (DN). The DN is used to refer to the entry 

unambiguously. Each of the entry's attributes has a type and one or more values. The 

types are typically mnemonic strings, like "cn" for common name, or "mail" for email 

address. The syntax of values depends on the attribute type. For example, a cn 

attribute might contain the value “Babs Jensen”. A mail attribute might contain the 

value "babs@example.com". 

How is the information arranged? 

In LDAP, directory entries are arranged in a hierarchical tree-like structure. Traditionally, 

this structure reflected the geographic and/or organizational boundaries. Entries 

representing countries appear at the top of the tree. Below them are entries 

representing states and national organizations. Below them might be entries 

representing organizational units, people, printers, documents, or just about anything 

else you can think of. The following shows an example of LDAP directory tree using 

traditional naming. 

 

LDAP lets you “locate organizations, individuals, and other resources such as files and 

devices in a network, whether on the Internet or on a corporate intranet,” and whether 
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or not you know the domain name, IP address, or geographic whereabouts. An LDAP 

directory can be distributed among many servers on a network, then replicated and 

synchronized regularly. LDAP is particularly useful for storing information that you wish to 

read from many locations, but update infrequently. 

Yealink IP phones with the firmware version 61 or higher support the LDAP feature. This 

guide provides the configurations on the LDAP server and the SIP-T46G IP phones 

running the firmware version 71. 
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An LDAP server is essentially a bit like an SQL server, which is mainly used for 

storing/retrieving information about people (such as contacts). The configuration 

settings on the phone will be altered depending on how the LDAP server is configured. 

Before using the LDAP feature on IP phones, you must make sure the LDAP server is 

prepared properly, otherwise you need to install and configure an LDAP server. This 

chapter shows you how to install and configure an LDAP server. We recommend you to 

use the OpenLDAP or Microsoft Active Directory in windows system. 

This section shows you how to install an OpenLDAP server. The OpenLDAP server 

software is available for free. You can download it from 

http://www.openldap.org/software/download/. 

To install the OpenLDAP server: 

1. Double click the OpenLDAP application to start the installation. Follow the default 

settings and click Next. 

2. Click Browse to locate the installation path from local computer system and then 

click Next. 

You need to remember the installation path (e.g., C:\OpenLDAP) located here. 

The screenshot for reference is shown as below: 
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3. Select Full installation, the screenshot for reference is shown as below: 

 

4. Follow the default settings and click Next. 

5. Click Finish to finish the installation. 

Access the slapd.conf file at the OpenLDAP installation path. Open and edit the 

slapd.conf file using your favorite text editor. 

1. Add the schema commands. 

Find the command include   ./schema/core.schema and add the following 

commands below it. 

These two commands must be added: 

include   ./schema/cosine.schema 

include   ./schema/inetorgperson.schema 

These commands can be added optionally: 

include   ./schema/corba.schema 

include   ./schema/dyngroup.schema 

include   ./schema/java.schema 

include   ./schema/misc.schema 

include   ./schema/nis.schema 

include   ./schema/openldap.schema 

2. Edit the manager information for LDAP phonebook. 

Find the commands  

Suffix  "dc=my-domain, dc=com" 

Rootdn  "cn=manager,dc=my-domain,dc=com" 

Rootpw  secret 

VoIPon   www.voipon.co.uk   sales@voipon.co.uk   Tel: +44 (0)1245 808195   Fax: +44 (0)1245 808299 



  Installing and Configuring the LDAP Server 

5

Suffix defines the components of the domain name. 

Rootdn defines the manager as a management user for accessing the LDAP server.  

Rootpw defines the user password of the management user. 

For example: 

Suffix  "dc=yealink,dc=cn" 

Rootdn  "cn=manager,dc=yealink,dc=cn" 

Rootpw  secret 

The suffix line means that the domain name of the LDAP phonebook is yealink.cn. 

The Rootdn line defines a management user named as manager. The Rootpw line 

defines the password “secret” for the management user. 

If the domain name contains additional components, for example, yealink.com.cn, 

the suffix line will be edited as below: 

Suffix  "dc=yealink,dc=com,dc=cn" 

Rootdn  "cn=manager,dc=yealink,dc=com,dc=cn" 

Rootpw  secret 

To start the slapd server: 

1. Click Start->Run. 

2. Enter cmd in the pop-up dialogue box and click OK to enter the command line 

interface. 

3. Execute the cd command to locate the server installation path. For example, 

execute cd c:\OpenLDAP to locate the server installation path at c:\OpenLDAP 

 

4. Execute the command slapd –d 1 to start the slapd server. 
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If the server runs successfully, you can find the prompt “slapd starting”. 

The screenshot for reference is shown as below: 

 

Please do not close this window to make sure the LDAP server keep running. 

You can add the initial entry to the LDAP directory by the ldif file. Create a new text 

document, then modify the filename extension as ldif and place the document to the 

OpenLDAP installation path. For example, create a text document named as test.txt, 

right click the test.txt document and then select to rename it, modify the filename 

extension as ldif. Open the ldif file with your favorite text editor and input the 

corresponding content. The following shows an example of the content of the LDIF file: 

dn: dc=yealink,dc=cn 

objectclass: dcobject 

objectclass: organization 

o: xmyealink 

dc: yealink 

 

dn: cn=manager,dc=yealink,dc=cn 

dc=yealink 

objectclass: dcobject 

objectclass: organization 

cn=manager 

sn: sumer 

To add the initial entry using the test.ldif file: 

1. Click Start->Run. 

2. Execute cmd in the pop-up dialogue box and click OK to enter the command line 

interface. 
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3. Execute the command cd c:\OpenLDAP to access the OpenLDAP installation path at 

c:\OpenLDAP. 

4. Execute the command ldapadd -x -D "cn=manager,dc=yealink,dc=cn" -w secret -f 

test.ldif to add the initial entry. 

The screenshot for reference is shown as below: 
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The LDAPExploreTool2 application supports to run in windows system. The application in 

windows is a graphical LDAP tool that enables you to browse, modify and manage 

contact entry on LDAP server. 

If you have an LDAPExploreTool2 application installed on your computer, open it now, 

otherwise, download the application from http://ldaptool.sourceforge.net/. And then 

complete the installation following the wizard. 

To create a configuration: 

1. Double click the LDAPExploreTool2.exe to start the application.  

2. Click File->Configurations. 

 

3. Click New to create a new configuration. 

4. Enter a name in the Configuration name field under the Configuration tab. 

 

5. Enter the domain name or IP address of the LDAP server in the Server name or IP 

field under the Server tab. Select to use the default port for the Server port and 
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Server SSL port. 

 

6. Enter the user DN and password in the User DN and Password field under the 

Connection tab.  

The user DN and password correspond with the Rootdn and Rootpw defined in the 

slapd.conf file. 

For example, according to the manager information defined in the slapd.conf file: 

Rootdn  "cn=manager,dc=yealink,dc=cn" 

Rootpw  secret 

Enter cn=manager,dc=yealink,dc=cn in the User DN field and secret in the 

Password field under the Connection tab. 

 

7. Click Guess value to fill the Base DN automatically. 

8. Click Test connection to test the connection to the LDAP server. If you encounter an 

error or warning during the test, you need to resolve the error or warning first 

according to the prompt, and then retry to test the connection. 
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9. Click OK to accept the change. 

To add entries: 

1. Click File->Configurations, select the configuration created above, and then click 

Open.  

The screenshot for reference is shown as below: 

 

2. Right click the root entry, and then select Add to add a new entry. 

 

3. Enter the desired values in the corresponding fields. 

Parent DN: It will be automatically generated according to the server configuration. 

Entry RDN: The format is cn=XXX. This is a unique identifier for each entry. 

Object Class (from schema): Select the structure class which the entry belongs to. 

Each structure class has its own must attributes and may attributes. We select 

Person from the pull-down list of Object class (from schema) for example. 

4. Select the desired attributes for object class. 

Must attributes: Double click attributes to add them to the entry node. All attributes 

listed in the Must attributes field must be added and each value of the attribute 

must be set. 

May attributes: Double click the desired attributes to add them to the entry node. 

The attributes listed in the May attributes field is optional. 
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Common attributes are listed in the following table:  

Attribute Name Description 

cn commonName Full name of the entry. 

gn givenName 
First name also called Christian 

name. 

sn surname 
Surname, last name or family 

name. 

telephoneNumber telephoneNumber Office phone number. 

homePhone homeTelephoneNumber Home phone number. 

mobile mobileTelephoneNumber 
Mobile or cellular phone 

number. 

pager pagerTelephoneNumber Pager telephone number. 

company company Company name. 

o organizationName Organization name. 

ou organizationlUnitName 
Usual department or any sub 

entity of larger entity. 

5. Right click the selected attribute and then select Add value. 

The screenshot of adding a new entry is shown as below: 

 

6. Click Save to confirm the configuration. 

7. Repeat steps 2 to 6 to add more contact entries. 

The value of cn here must be the 

same as the value of cn configured 

in the Entry RDN field. 
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You can find the added entries at the left of the LDAP catalogue. 

 

This section shows you how to install an active directory on Microsoft windows server 

2008 R2 Enterprise 64-bit. 

To install the Microsoft active directory server: 

1. Click Start->Run. 

2. Enter dcpromo in the pop-up dialogue box and click OK. 

3. The Active Directory Domain Services Installation Wizard will appear after a short 

while, click Next. 
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4. Read the provided information and click Next. 

 

5. Mark the Create a new domain in a new forest radio box and click Next. 
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6. Enter an appropriate domain name for the forest root domain and click Next. 

 

The wizard will check to see if the domain name is not already in use on the local 

network. 

 

7. Select the desired forest functional level from the pull-down list of Forest functional 

level, and click Next. 
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For more information, click domain and forest functional levels. 

 

8. Select the desired domain functional level from the pull-down list of Domain 

functional level, and click Next. 

For more information, click domain and forest functional levels. 

 

  If you select Windows Server 2008 R2 for the forest functional level, you will not be 
prompted to enter a domain functional level. 
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The wizard will check to see if the DNS is properly configured on the local network. 

 

9. Select additional options for this domain controller if required, and click Next. 

 

 

  

You may get a warning telling you that the server has one or more dynamic IP 
addresses. We recommend assigning the static IP addresses to the physical 
network adapters. 
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10. The wizard will prompt a warning about DNS delegation. Since no DNS has been 

configured yet, you can ignore the message and click Yes. 

 

11. Specify the desired paths for the database, log files and SYSVOL folders, and click 

Next. 

For more information, click placing Active Directory Domain Services files. 
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12. Configure the password for the active directory recovery mode, click Directory 

Services Restore Mode password for more information and click Next. 

The password should be complex and at least 7 characters long. 

 

13. Review your selection and click Next. 
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The wizard will begin creating the Active Directory domain, and when finished, you 

will need to click Finish and reboot your computer. 

 

 

You should also install the Active Directory Lightweight Directory Services role on 

windows server 2008. 

To install the Active Directory Lightweight Directory Services role: 

1. Click Start->Administrative Tools->Server Manager. 

2. Right click Roles, and then select Add Roles. 
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3. The Add Roles Wizard will appear, click Next. 

 

4. Check the Active Directory Lightweight Directory Services checkbox and click Next. 

 

5. Follow the default settings and click Next. 

6. When the installation ends, click Close. 
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After the installation succeeds, you will find the Active Directory Lightweight 

Directory Services role below roles of the server manager. 

 

You can add entries to the active directory one by one in this way. 

To add an entry to the Active Directory: 

1. Click Start->Administrative Tools->Server Manager. 

2. Double click Roles->Active Directory Domain Services->Active Directory Users and 

Computers. 

3. Right click the domain name created above (e.g., ldap.yealink.com), and then 

select New->Organizational Unit. 
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4. Enter the desired name of the organizational unit. 

 

5. Click OK to accept the change. 

6. Right click the organizational unit created above, and then select New->Contact. 
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7. Enter the desired values in the corresponding fields. 

 

8. Click OK to accept the change. 

9. Double click the contact created above. 

10. Configure more properties of the contact. 

 

11. Click OK to accept the change. 
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You can use the LDIF file to perform a batch import of all entries to the active directory. 

Create a new text document and then modify the filename extension as ldif. For 

example, create a text document named as test.txt, right click the test.txt document and 

then select to rename it, modify the filename extension as ldif. Open the LDIF file with 

your favorite text editor and input the corresponding content. The following shows an 

example of the content of the LDIF file: 

 

To import the test.ldif file: 

1. Click Start->Run. 

2. Enter cmd in the pop-up dialogue box and click OK to enter the command line 

interface. 

  

##Create a new organizational unit## 

dn: OU=yealink,DC=ldap,DC=yealink,DC=com 

changetype: add 

objectClass: top 

objectClass: organizationalUnit 

ou: yealink 

name: yealink 

 

##create a new contact## 

dn: CN=san zhang,OU=yealink,DC=ldap,DC=yealink,DC=com 

changetype: add 

objectClass: top 

objectClass: person 

objectClass: organizationalPerson 

objectClass: contact 

cn: san zhang 

sn: zhang 

givenName: san 

initials: zs 

name: san zhang 

ipPhone: 2336 

mobile: 15557107369 
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3. Execute the command cd to access the path of the test.ldif file. For example, 

execute cd c:\Windows to access the path of the test.ldif file at c:\ Windows. 

 

4. Execute the command ldifde  -i  -f  test.ldif to import the file. 

If the entries are added successfully, you can find the prompt “n entries modified 

successfully” ("n" indicates the number of the added entries). 

The screenshot for reference is shown as below: 

 

 

 

You can also export the existing entries on the active directory into a *.ldif file first, 
modify the file, and then import the modified file into the active directory. For 
more information, refer to the network resource. 
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You can also use the CSV file to perform a batch import of all entries to the active 

directory. Create a new document using a spreadsheet application (e.g., Microsoft 

Excel) and then save the document to your local computer using “Save as” in the format 

“*.csv”. For example, create a document named as test.xls, click “Save as” to save the 

document as test.csv. Open the CSV file with the spreadsheet application and input the 

corresponding content. The following shows an example of the content of the CSV file: 

 

 

To import the test.csv file: 

1. Click Start->Run. 

2. Enter cmd in the pop-up dialogue box and click OK to enter the command line 

interface. 

3. Execute the command cd to access the path of the user.csv file. For example, 

execute cd c:\Windows to access the path of the user.csv file at c:\Windows. 

 

4. Execute the command csvde  -i  -f  test.csv to import the file. 

  

The first line lists the attributes of the entries. 

The second line lists the values of an organizational unit in the corresponding attribute 
columns. 

The other lines list the values of contacts in the corresponding attribute columns. 
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If the entries are added successfully, you can find the prompt “n entries modified 

successfully” ("n" indicates the number of the added entries). 

The screenshot for reference is shown as below: 

 

 

You can create user accounts to allow or deny access to resources on the active 

directory. User accounts are very important and useful. 

To create a user account: 

1. Click Start->Administrative Tools->Server Manager. 

2. Double click Server Manager->Roles->Active Directory Domain Services->Active 

Directory Users and Computers. 

3. Select the domain name created above (e.g.,ldap.yealink.com). 

4. Right click Users, and then select New->User. 

 

  

The idifde tool cannot edit or delete the existing entries on the active directory.  

You can also export the existing entries on the active directory into a *.csv file first, 
modify the file, and then import the modified file into the active directory. For 
more information, refer to the network resource. 
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5. Enter desired values in the corresponding fields and click Next. 

 

6. Enter the password for the user, select the appropriate options and click Next. 

The password should be a combination of upper case letters, lower case letters, 

numbers and special characters. 
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7. Click Finish to complete the creation of the user account. 
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LDAP is disabled on the IP phone by default. You can configure LDAP via web user 

interface or using the configuration files. 

To configure the LDAP feature via web user interface: 

1. Press the OK key on the phone when it is idle to obtain the IP address. 

2. Enter the IP address (e.g., http://192.168.0.10 or 192.168.0.10) in the address bar of 

web browser on your PC and then press Enter. 

3. Enter the user name and password in the login page. 

The default login user name is admin (case-sensitive) and the password is admin 

(case-sensitive). 

4. Click on Contacts->LDAP. 

5. Select Enabled from the pull-down list of Enable LDAP. 

6. Enter the desired values in the corresponding fields. 

The screenshot for reference is shown as below: 

 

7. Click Confirm to accept the change. 
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LDAP Attributes on Web User Interface 

Enable LDAP 

Description This parameter enables the LDAP feature on the IP phone. 

Valid Value <Enabled>, <Disabled> 

Default Value Disabled 

LDAP Name Filter 

Description This parameter specifies the name attributes for LDAP searching. 

The format of the search filter is compliant to the standard string 

representations of LDAP search filters (RFC 2254). The “*” symbol in 

the filter stands for any character. The “%” symbol in the filter stands 

for the entering string used as the prefix of the filter condition. 

Example  (|(cn=%)(sn=%)) 

When the name prefix of the cn or sn of the contact record 

matches the search criteria, the record will be displayed on the 

phone LCD screen. 

 (&(cn=*)(sn=%)) 

When the name prefix of the sn of the contact record matches 

the search criteria, the record will be displayed on the phone 

LCD screen. 

 (!(cn=%)) 

When the name prefix of the cn of the contact record does not 

match the search criteria, the record will be displayed on the 

phone LCD screen. 

LDAP Number Filter 

Description This parameter specifies the number attributes for LDAP searching. 

The format of the search filter is compliant to the standard string 

representations of LDAP search filters (RFC 2254). The “*” symbol in 

the filter stands for any character. The “%” symbol in the filter stands 

for the entering string used as the prefix of the filter condition. 

Examples  (|(telephoneNumber=%)(Mobile=%)(ipPhone=%)) 

When the number prefix of the telephoneNumber, Mobile or 

ipPhone of the contact record matches the search criteria, the 

record will be displayed on the phone LCD screen. 

 (&(telephoneNumber=*)(Mobile=%)) 

When the number prefix of the Mobile of the contact record 

matches the search criteria, the record will be displayed on the 

phone LCD screen. 
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Server Address 

Description This parameter specifies the domain name or IP address of the LDAP 

server. 

Default Value Blank 

Example  192.168.1.100 

 ldap.company.com 

Port 

Description This parameter specifies the LDAP server port. 

Default Value 389 

Base 

Description This parameter specifies the LDAP search base which corresponds 

to the location in the LDAP phonebook. The search base narrows the 

search scope and decreases directory search time. 

Example  o=UNIVERSITY OF NEW ORLEANS,c=US 

 o=SFU,c=CA 

 dc=yealink,dc=cn 

UserName 

Description This parameter specifies the user name to login the LDAP server. If 

the LDAP server allows anonymous to login, this parameter can be 

left blank. Otherwise you need to provide the username to access 

the LDAP server. 

Password 

Description This parameter specifies the password to login the LDAP server. If 

the LDAP server allows anonymous to login, this parameter can be 

left blank. Otherwise you need to provide the password to access 

the LDAP server. 

Max.Hits(1~32000) 

Description This parameter specifies the maximum number of the search results 

to be returned by the LDAP server. If the value of the “Max.Hits” is 

blank, the LDAP server will return all searched results. Please note 

that a very large value of the “Max. Hits” will slow down the LDAP 

search speed, therefore the parameter should be configured 

according to the available bandwidth. 

Default Value 50 

LDAP Name Attributes 
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Description This parameter specifies the name attributes of each record to be 

returned by the LDAP server. This parameter compresses the search 

results. The user can configure multiple name attributes separated 

by space. 

Example  cn sn displayName 

This requires the “cn”, “sn” and “displayName” attributes set 

for each contact record on the LDAP server. 

 givenName 

This requires the “givenName” attribute set for each contact 

record on the LDAP server. 

LDAP Number Attributes 

Description This parameter specifies the number attributes of each record to be 

returned by the LDAP server. This parameter compresses the search 

results. The user can configure multiple number attributes separated 

by space. 

Example  Mobile telephoneNumber ipPhone 

This requires the “Mobile”, “telephoneNumber” and “ipPhone” 

attributes set for each contact record on the LDAP server. 

LDAP Display Name 

Description This parameter specifies the display name of the contact record 

displayed on the LCD screen. This parameter value must start with 

“%” symbol. 

Example  %cn 

The desired display name of the contact record is the cn 

attribute. 

Protocol 

Description This parameter specifies the LDAP protocol version supported on the 

phone. Make sure the protocol value corresponds with the version 

assigned on the LDAP server. 

Valid Value Version 2 or 3 

Default Value Version 3 

LDAP Lookup For Incoming Call 

Description This parameter enables the phone to perform an LDAP search when 

receiving an incoming call.  

Valid Value <Enabled>, <Disabled> 

Default Value Disabled 
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LDAP Sorting Results 

Description This parameter enables the phone to sort the search results in 

alphabetical order or numerical order. 

Valid Value <Enabled>, <Disabled> 

Default Value Disabled 

Example for Configuration 

You can use the following settings as a starting point and adjust the filter and display 

attributes according to your needs. 

Enable LDAP: Enabled 

LDAP Name Filter: (|(cn=%)(sn=%)) 

LDAP Number Filter: (|(telephoneNumber=%)(Mobile=%)(ipPhone=%)) 

Server Address: 192.168.1.30 

Port: 389 

Base: dc=yealink,dc=cn 

UserName: cn=manager,dc=yealink,dc=cn 

Password: secret 

Max.Hits(1~32000): 50 

LDAP Name Attributes: cn sn 

LDAP Number Attributes: Mobile telephoneNumber ipPhone 

LDAP Display Name: %cn 

Protocol: Version 3 

LDAP Lookup For Incoming Call: Enabled 

LDAP Sorting Results: Enabled 

To use the LDAP feature, you need to configure a DSS key as an LDAP key. 

To configure an LDAP key via web user interface: 

1. Log into the web user interface of the phone. 

2. Click on DSSKey->Line Key. 
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3. In the desired DSS key field, select LDAP from the pull-down list of Type. 

 

4. Click Confirm to accept the change. 

To configure the LDAP feature using the configuration file: 

1. Add/Edit the LDAP parameters in the configuration file. 

The following table shows the parameter information: 

Parameter Descriptions Web Setting Path 

ldap.enable 

These parameters 

specify the LDAP 

attributes. 

Refer to the 

introduction above 

for more 

information. 

Contacts->LDAP->Enable 

LDAP 

ldap.name_filter 
Contacts->LDAP->LDAP 

Name Filter 

ldap.number_filter 
Contacts->LDAP->LDAP 

Number Filter 

ldap.host 
Contacts->LDAP->Server 

Address 

ldap.port Contacts->LDAP->Port 

ldap.base Contacts->LDAP->Base 

ldap.user Contacts->LDAP->Username 

ldap.password Contacts->LDAP->Password 

ldap.max_hits 
Contacts->LDAP->Max. Hits 

(1~32000) 

ldap.name_attr 
Contacts->LDAP->LDAP 

Name Attributes 

ldap.numb_attr Contacts->LDAP->LDAP 
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Parameter Descriptions Web Setting Path 

Number Attributes 

ldap.display_name 
Contacts->LDAP->LDAP 

Display Name 

ldap.version Contacts->LDAP->Protocol 

ldap.call_in_lookup 
Contacts->LDAP->LDAP 

Lookup For Incoming Call 

ldap.ldap_sort 
Contacts->LDAP->LDAP 

Sorting Results 

2. Upload the configuration file to the root directory of the provisioning server and 

perform auto provisioning to configure the Yealink IP phones. 

For more information on auto provisioning, refer to Yealink SIP-T46G Auto 

Provisioning User Guide. 

To configure an LDAP key using the configuration file: 

1. Add/Edit the LDAP key parameters in the configuration file. 

The following table shows the parameter information: 

Parameter Description Value 

linekey.x.type 

Configures a line key to be 

LDAP key on the IP phone. 

X ranges from 1 to 27. 

38 

2. Upload the configuration file to the root directory of the provisioning server and 

perform auto provisioning to configure the Yealink IP phones. 

For more information on auto provisioning, refer to Yealink SIP-T46G Auto 

Provisioning User Guide. 
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You can press the LDAP key to access the LDAP phonebook. Enter the search criteria to 

search a contact from LDAP phonebook, add local contacts from LDAP phonebook, and 

dial a contact from LDAP phonebook. You can also enable the phone to perform a LDAP 

search when dialing out or receiving an incoming call. 

To search a contact form LDAP phonebook: 

1. Press the LDAP key to access the LDAP phonebook. 

The LCD screen prompts “None”. 

 

2. Enter a few continuous characters of the contact name or continuous digits of the 

contact phone number using the keypad. 

 

The contacts whose name or phone number matches the characters entered will 

appear on the LCD screen. 

3. Press the navigation key to select the desired contact. 

4. Do one of the following: 

- Press the Option soft key and then select to check the detail information of the 

contact. 

- Press the Option soft key and then select to add the contact to the local 

contact. 
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- Press the dial soft key to dial out. 

If the LDAP Lookup For Incoming Call parameter is enabled for the phone: 

The phone performs an LDAP search when receiving an incoming call. If there is a 

contact record which matches the caller ID, the contact name will be display on the 

phone LCD screen as the calling line identification. 

The screenshot of the LCD screen for reference is shown as below: 

 

The Search Source List In Dialing feature enables the phone to perform an LDAP search 

when you enter the digits using the keypad on the pre-dial interface. For more 

information on the configuration of the Search Source List In Dialing feature, refer to 

Yealink SIP-T46G IP Phone User Guide. 

If there are contact records which match the search criteria, the contact records will be 

listed on the phone LCD screen. You can select the desired contact record to dial out. 

The contact name will be displayed on the phone LCD screen during the call. 

The screenshot of the LCD screen for reference is shown as below: 
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